TPSA Namespace

[image]

A Sandcastle Documented Class Library
TPSA Namespace
Send Feedback

[Missing <summary> documentation for "N:TPSA"]

Classes

 | Class | Description
Public class | TPSA | Numerical implementation of Truncated Power Series Algebra (TPSA).
Public class | TPSAMaps | TPSAMaps models maps (coordinate transformations) using the algebra of truncated power series (polynomials of fixed maximum degree).

Enumerations

 | Enumeration | Description
Public enumeration | TPSAMaps..::..Create | Enumeration used to tell the constructor whether to fully instantiate a new map, or else to define the pointers only deferring assignment.


TPSA Class

[image]

A Sandcastle Documented Class Library
TPSA Class
Members See Also Send Feedback
Numerical implementation of Truncated Power Series Algebra (TPSA).

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TPSA
Visual Basic
Public Class TPSA
Visual C++
public ref class TPSA

Remarks

This class models polynomials in one or more variables and a given order.

Some methods employ operator overloading, while other faster methods overwrite the instance.

Effort was put into speeding up the code. For example, there are methods that modify the instance and create no new objects for intermediate values. These methods are faster and should be used in critical sections of code when possible.

This class cannot model more that one TPSA at a time.

Inheritance Hierarchy

System..::..Object
TPSA..::..TPSA

See Also

TPSA Members
TPSA Namespace


TPSA Members

[image] [image]

A Sandcastle Documented Class Library
TPSA Members
TPSA Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TPSA type exposes the following members.

Constructors

 | Name | Description
Public method | TPSA | Creates a new TPSA object.

Methods

 | Name | Description
Public method | arcsin | Arc sine function.
Public method | arctan | Arc tangent function.
Public method | BesselJ | Bessel J function.
Public method | BesselJ0 | Bessel J0 function.
 | binomial | Computes the binomial coefficient of the two arguments.
Public method | Clear(Double) | Clears the instance and sets the constant term to the value of the optional argument.
Public method | Clear(array<Int32>[]()[][]%) | Clears specific terms of the instance specified by an array of indices.
Public method | clone | Creates a new copy of the instance.
Public method | comp | Performs the function composition of the instance and an array of TPSA objects.
Public method | copy | Copy the argument to the instance.
Public method | cos | Cosine function.
Public method | cosh | Hyperbolic cosine function.
Public method | cotan | Cotangent function.
Public method | cotanh | Hyperbolic cotangent function.
Public method | csc | Cosecant function.
Public method | csch | Hyperbolic cosecant function.
Public method | Divide(Double) | Divides the instance by a double.
Public method | Divide(TPSA%) | Divides the instance by a TPSA object and returns itself.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Eval(array<Double>[]()[][]) | Evaluate the instance at numerical values of the variables.
Public method | Eval(array<array<Double>[]()[][]>[]()[][]) | Evalutes the instance at a set of numerical values of the variables.
Public method | exp | Exponential function.
 | factorial | The factorial of the integer argument.
Public method | Filter | Zeros coefficients of the instance corresponding to an array of indices.
Public method | FilterKeep | Returns the complement of Filter.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetTerm | Returns the coefficient of the term with variables having the exponents of the argument.
 | GetTermIndex | Returns the index in tps of the term with variables having the exponents of the argument.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | grad | Returns the gradient of the instance as an array of TPSA objects.
 | Init | Initializes the class for creating TPSA objects of the given number of variable and order.
Public method | Inverse | The multiplicative inverse of the instance.
Public method | log | Log function.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus()()()() | Converts the instance to its arithmetic negative.
Public method | Minus(Double) | Subtracts a real value from the instance. Something like a -= operator.
Public method | Minus(TPSA) | Subtracts a TPSA object from the instance.
 | one | Returns the unit element or elements representing the variables depending on the argument.
Public method | Plus(Double) | Adds a real value to the instance. Something like a += operator.
Public method | Plus(array<TPSA>[]()[][]) | Adds a TPSA object to the instance. Something like a += operator.
Public method | Power | Raises the instance to a power and returns itself.
Public method | sec | Secant function.
Public method | sech | Hyperbolic secant function.
Public method | SetOrder | Clips terms of the instance whose order is either higher or lower than a given value, and returns a new object.
Public method | sin | Sine function.
Public method | sinh | Hyperbolic sine function.
 | sort | Sorts jagged arrays of integers.
Public method | sqrt | The square root of the instance.
Public method | tan | Tangent function.
Public method | tanh | Hyperbolic tangent function.
Public method | Times(Double) | Multiplies the instance by a double.
Public method | Times(array<TPSA>[]()[][]) | Multiplies the instance by a TPSA object and returns itself.
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(Double, String) | Returns a string representation of the instance.

Operators

Name | Description
Addition(Double, TPSA) | Adds a double to a TPSA object.
Addition(TPSA, Double) | The addition operator that acts on two instances.
Addition(TPSA, TPSA) | Overloaded addition operator for two TPSA objects.
Division(Double, TPSA) | Divides a double by a TPSA object.
Division(TPSA, Double) | Divides a TPSA object by a double.
Division(TPSA, TPSA) | Divide two TPSA objects.
Exponent | Raises the instance to a power.
Multiply(Double, TPSA) | Multiplies a TPSA object by a double.
Multiply(TPSA, Double) | Overloade multiply a TPSA object by a double.
Multiply(TPSA, TPSA) | Multiply two TPSA objects.
Subtraction(Double, TPSA) | Overloaded subtraction operator with one argument being a double.
Subtraction(TPSA, Double) | The subtraction operator that acts on two instances.
Subtraction(TPSA, TPSA) | Overloaded subtraction operator for two TPSA objects.
UnaryNegation | The arithmetic negative of the instance.

Fields

 | Name | Description
 | exponents | A list of TPSATerms lists, each consisting of a list, corresponding to its term, of exponents of the variables.
 | order | A list of TPSATerms integers, each consisting of the order of the corresponding term.
Public field | tps | The coefficients of the object.
 | vars | A list of TPSA objects representing the variables of the algebra, i.e., each is a polynomial whose only nonzero coefficient is the one corresponding the linear term of its variable and having value unity.
 | zero | The zero element of the algebra.

Properties

Name | Description
TPSAOrder | Order of the TPSA.
TPSATerms | The number of terms in the TPSA.
TPSAVariables | The number of variables in the TPSA.

See Also

TPSA Class


TPSA Constructor

[image]

A Sandcastle Documented Class Library
TPSA Constructor
TPSA Class See Also Send Feedback
Creates a new TPSA object.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA()
Visual Basic
Public Sub New
Visual C++
public:
TPSA()

See Also

TPSA Class
TPSA Members


TPSA Fields

[image] [image]

A Sandcastle Documented Class Library
TPSA Fields
TPSA Class See Also Send Feedback

The TPSA type exposes the following members.

Fields

 | Name | Description
 | exponents | A list of TPSATerms lists, each consisting of a list, corresponding to its term, of exponents of the variables.
 | order | A list of TPSATerms integers, each consisting of the order of the corresponding term.
Public field | tps | The coefficients of the object.
 | vars | A list of TPSA objects representing the variables of the algebra, i.e., each is a polynomial whose only nonzero coefficient is the one corresponding the linear term of its variable and having value unity.
 | zero | The zero element of the algebra.

See Also

TPSA Class


exponents Field

[image]

A Sandcastle Documented Class Library
TPSA..::..exponents Field
TPSA Class See Also Send Feedback
A list of TPSATerms lists, each consisting of a list, corresponding to its term, of exponents of the variables.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int[][] exponents
Visual Basic
Public Shared exponents As Integer()()
Visual C++
public:
static array<array<int>^>^ exponents

Remarks

Instantiated for convenience.

See Also

TPSA Class
TPSA Members


order Field

[image]

A Sandcastle Documented Class Library
TPSA..::..order Field
TPSA Class See Also Send Feedback
A list of TPSATerms integers, each consisting of the order of the corresponding term.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int[] order
Visual Basic
Public Shared order As Integer()
Visual C++
public:
static array<int>^ order

Remarks

Instantiated for convenience.

See Also

TPSA Class
TPSA Members


tps Field

[image]

A Sandcastle Documented Class Library
TPSA..::..tps Field
TPSA Class See Also Send Feedback
The coefficients of the object.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[] tps
Visual Basic
Public tps As Double()
Visual C++
public:
array<double>^ tps

Remarks

This property contains the coefficients of the polynomial represented by the instance.

See Also

TPSA Class
TPSA Members


vars Field

[image]

A Sandcastle Documented Class Library
TPSA..::..vars Field
TPSA Class See Also Send Feedback
A list of TPSA objects representing the variables of the algebra, i.e., each is a polynomial whose only nonzero coefficient is the one corresponding the linear term of its variable and having value unity.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA[] vars
Visual Basic
Public Shared vars As TPSA()
Visual C++
public:
static array<TPSA^>^ vars

Remarks

Instantiated for convenience.

See Also

TPSA Class
TPSA Members


zero Field

[image]

A Sandcastle Documented Class Library
TPSA..::..zero Field
TPSA Class See Also Send Feedback
The zero element of the algebra.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA zero
Visual Basic
Public Shared zero As TPSA
Visual C++
public:
static TPSA^ zero

Remarks

Instantiated for convenience.

See Also

TPSA Class
TPSA Members


TPSA Methods

[image] [image]

A Sandcastle Documented Class Library
TPSA Methods
TPSA Class See Also Send Feedback

The TPSA type exposes the following members.

Methods

 | Name | Description
Public method | arcsin | Arc sine function.
Public method | arctan | Arc tangent function.
Public method | BesselJ | Bessel J function.
Public method | BesselJ0 | Bessel J0 function.
 | binomial | Computes the binomial coefficient of the two arguments.
Public method | Clear(Double) | Clears the instance and sets the constant term to the value of the optional argument.
Public method | Clear(array<Int32>[]()[][]%) | Clears specific terms of the instance specified by an array of indices.
Public method | clone | Creates a new copy of the instance.
Public method | comp | Performs the function composition of the instance and an array of TPSA objects.
Public method | copy | Copy the argument to the instance.
Public method | cos | Cosine function.
Public method | cosh | Hyperbolic cosine function.
Public method | cotan | Cotangent function.
Public method | cotanh | Hyperbolic cotangent function.
Public method | csc | Cosecant function.
Public method | csch | Hyperbolic cosecant function.
Public method | Divide(Double) | Divides the instance by a double.
Public method | Divide(TPSA%) | Divides the instance by a TPSA object and returns itself.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Eval(array<Double>[]()[][]) | Evaluate the instance at numerical values of the variables.
Public method | Eval(array<array<Double>[]()[][]>[]()[][]) | Evalutes the instance at a set of numerical values of the variables.
Public method | exp | Exponential function.
 | factorial | The factorial of the integer argument.
Public method | Filter | Zeros coefficients of the instance corresponding to an array of indices.
Public method | FilterKeep | Returns the complement of Filter.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetTerm | Returns the coefficient of the term with variables having the exponents of the argument.
 | GetTermIndex | Returns the index in tps of the term with variables having the exponents of the argument.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | grad | Returns the gradient of the instance as an array of TPSA objects.
 | Init | Initializes the class for creating TPSA objects of the given number of variable and order.
Public method | Inverse | The multiplicative inverse of the instance.
Public method | log | Log function.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus()()()() | Converts the instance to its arithmetic negative.
Public method | Minus(Double) | Subtracts a real value from the instance. Something like a -= operator.
Public method | Minus(TPSA) | Subtracts a TPSA object from the instance.
 | one | Returns the unit element or elements representing the variables depending on the argument.
Public method | Plus(Double) | Adds a real value to the instance. Something like a += operator.
Public method | Plus(array<TPSA>[]()[][]) | Adds a TPSA object to the instance. Something like a += operator.
Public method | Power | Raises the instance to a power and returns itself.
Public method | sec | Secant function.
Public method | sech | Hyperbolic secant function.
Public method | SetOrder | Clips terms of the instance whose order is either higher or lower than a given value, and returns a new object.
Public method | sin | Sine function.
Public method | sinh | Hyperbolic sine function.
 | sort | Sorts jagged arrays of integers.
Public method | sqrt | The square root of the instance.
Public method | tan | Tangent function.
Public method | tanh | Hyperbolic tangent function.
Public method | Times(Double) | Multiplies the instance by a double.
Public method | Times(array<TPSA>[]()[][]) | Multiplies the instance by a TPSA object and returns itself.
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(Double, String) | Returns a string representation of the instance.

See Also

TPSA Class


arcsin Method

[image]

A Sandcastle Documented Class Library
TPSA..::..arcsin Method
TPSA Class See Also Send Feedback
Arc sine function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA arcsin()
Visual Basic
Public Function arcsin As TPSA
Visual C++
public:
TPSA^ arcsin()

Return Value

The arc sine of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


arctan Method

[image]

A Sandcastle Documented Class Library
TPSA..::..arctan Method
TPSA Class See Also Send Feedback
Arc tangent function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA arctan()
Visual Basic
Public Function arctan As TPSA
Visual C++
public:
TPSA^ arctan()

Return Value

The arc tangent of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


BesselJ Method

[image]

A Sandcastle Documented Class Library
TPSA..::..BesselJ Method
TPSA Class See Also Send Feedback
Bessel J function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA BesselJ(
    int nu
)
Visual Basic
Public Function BesselJ ( _
    nu As Integer _
) As TPSA
Visual C++
public:
TPSA^ BesselJ(
    int nu
)

Parameters

nu
Type: System..::..Int32
The bessel order.

Return Value

The Bessel J of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


BesselJ0 Method

[image]

A Sandcastle Documented Class Library
TPSA..::..BesselJ0 Method
TPSA Class See Also Send Feedback
Bessel J0 function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA BesselJ0()
Visual Basic
Public Function BesselJ0 As TPSA
Visual C++
public:
TPSA^ BesselJ0()

Return Value

The Bessel J0 of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


binomial Method

[image]

A Sandcastle Documented Class Library
TPSA..::..binomial Method
TPSA Class See Also Send Feedback
Computes the binomial coefficient of the two arguments.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int binomial(
    int k,
    int l
)
Visual Basic
Public Shared Function binomial ( _
    k As Integer, _
    l As Integer _
) As Integer
Visual C++
public:
static int binomial(
    int k,
    int l
)

Parameters

k
Type: System..::..Int32
First argument.
l
Type: System..::..Int32
The second argument.

Return Value

The binomial coefficient.

Remarks

The binomial coefficient is k!/(l! (k-l)!). This function will not necessarily overflow when k! or l! overflow.

See Also

TPSA Class
TPSA Members


Clear Method

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Clear Method
TPSA Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear(Double) | Clears the instance and sets the constant term to the value of the optional argument.
Public method | Clear(array<Int32>[]()[][]%) | Clears specific terms of the instance specified by an array of indices.

See Also

TPSA Class
TPSA Members


Clear Method (Double)

[image]

A Sandcastle Documented Class Library
TPSA..::..Clear Method (Double)
TPSA Class See Also Send Feedback
Clears the instance and sets the constant term to the value of the optional argument.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Clear(
    double x = 0
)
Visual Basic
Public Function Clear ( _
    Optional x As Double = 0 _
) As TPSA
Visual C++
public:
TPSA^ Clear(
    double x = 0
)

Parameters

x (Optional)
Type: System..::..Double
The optional constant-term value.

Return Value

[Missing <returns> documentation for "M:TPSA.TPSA.Clear(System.Double)"]

See Also

TPSA Class
TPSA Members
Clear Overload


Clear Method (Int32[])

[image]

A Sandcastle Documented Class Library
TPSA..::..Clear Method (array<Int32>[]()[][]%)
TPSA Class See Also Send Feedback
Clears specific terms of the instance specified by an array of indices.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Clear(
    ref int[] t
)
Visual Basic
Public Function Clear ( _
    ByRef t As Integer() _
) As TPSA
Visual C++
public:
TPSA^ Clear(
    array<int>^% t
)

Parameters

t
Type: array<System..::..Int32>[]()[][]%
The array of indices corresponding to terms to be cleared.

Return Value

Itself.

Remarks

Equivalent to filter except that it acts on the instance instead of creating a new one. Does not create a new object, but modifies the instance.

See Also

TPSA Class
TPSA Members
Clear Overload


clone Method

[image]

A Sandcastle Documented Class Library
TPSA..::..clone Method
TPSA Class See Also Send Feedback
Creates a new copy of the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA clone()
Visual Basic
Public Function clone As TPSA
Visual C++
public:
TPSA^ clone()

Return Value

The new copy of the instance.

See Also

TPSA Class
TPSA Members


comp Method

[image]

A Sandcastle Documented Class Library
TPSA..::..comp Method
TPSA Class See Also Send Feedback
Performs the function composition of the instance and an array of TPSA objects.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA comp(
    ref TPSA[] a
)
Visual Basic
Public Function comp ( _
    ByRef a As TPSA() _
) As TPSA
Visual C++
public:
TPSA^ comp(
    array<TPSA^>^% a
)

Parameters

a
Type: array< TPSA..::..TPSA >[]()[][]%
The array of TPSA objects that are interpreted as the variables of the instance.

Return Value

The composition.

Remarks

The number of TPSA objects of the array argument must be equal to the number of variables of the TPSA.

Exceptions

Exception | Condition
[ApplicationException] | When the number of elements of a is not the same as the number of variables in the TPSA.

See Also

TPSA Class
TPSA Members


copy Method

[image]

A Sandcastle Documented Class Library
TPSA..::..copy Method
TPSA Class See Also Send Feedback
Copy the argument to the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void copy(
    ref TPSA source
)
Visual Basic
Public Sub copy ( _
    ByRef source As TPSA _
)
Visual C++
public:
void copy(
    TPSA^% source
)

Parameters

source
Type: TPSA..::..TPSA %
The element of the algebra to be copied.

Remarks

Clones a map to the instance. Does not create a new instance.

See Also

TPSA Class
TPSA Members


cos Method

[image]

A Sandcastle Documented Class Library
TPSA..::..cos Method
TPSA Class See Also Send Feedback
Cosine function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA cos()
Visual Basic
Public Function cos As TPSA
Visual C++
public:
TPSA^ cos()

Return Value

The cosine of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


cosh Method

[image]

A Sandcastle Documented Class Library
TPSA..::..cosh Method
TPSA Class See Also Send Feedback
Hyperbolic cosine function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA cosh()
Visual Basic
Public Function cosh As TPSA
Visual C++
public:
TPSA^ cosh()

Return Value

The hyperbolic cosine of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


cotan Method

[image]

A Sandcastle Documented Class Library
TPSA..::..cotan Method
TPSA Class See Also Send Feedback
Cotangent function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA cotan()
Visual Basic
Public Function cotan As TPSA
Visual C++
public:
TPSA^ cotan()

Return Value

The cotangent of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


cotanh Method

[image]

A Sandcastle Documented Class Library
TPSA..::..cotanh Method
TPSA Class See Also Send Feedback
Hyperbolic cotangent function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA cotanh()
Visual Basic
Public Function cotanh As TPSA
Visual C++
public:
TPSA^ cotanh()

Return Value

The hyperbolic cotangent of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


csc Method

[image]

A Sandcastle Documented Class Library
TPSA..::..csc Method
TPSA Class See Also Send Feedback
Cosecant function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA csc()
Visual Basic
Public Function csc As TPSA
Visual C++
public:
TPSA^ csc()

Return Value

The cosecant of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


csch Method

[image]

A Sandcastle Documented Class Library
TPSA..::..csch Method
TPSA Class See Also Send Feedback
Hyperbolic cosecant function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA csch()
Visual Basic
Public Function csch As TPSA
Visual C++
public:
TPSA^ csch()

Return Value

The hyperbolic cosecant of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


Divide Method

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Divide Method
TPSA Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Divide(Double) | Divides the instance by a double.
Public method | Divide(TPSA%) | Divides the instance by a TPSA object and returns itself.

See Also

TPSA Class
TPSA Members


Divide Method (Double)

[image]

A Sandcastle Documented Class Library
TPSA..::..Divide Method (Double)
TPSA Class See Also Send Feedback
Divides the instance by a double.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Divide(
    double b
)
Visual Basic
Public Function Divide ( _
    b As Double _
) As TPSA
Visual C++
public:
TPSA^ Divide(
    double b
)

Parameters

b
Type: System..::..Double
The double the instance is to be divided by.

Return Value

Itself.

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSA Class
TPSA Members
Divide Overload


Divide Method (TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Divide Method (TPSA%)
TPSA Class See Also Send Feedback
Divides the instance by a TPSA object and returns itself.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Divide(
    ref TPSA b
)
Visual Basic
Public Function Divide ( _
    ByRef b As TPSA _
) As TPSA
Visual C++
public:
TPSA^ Divide(
    TPSA^% b
)

Parameters

b
Type: TPSA..::..TPSA %
The object the instance is to be divided by.

Return Value

Itself.

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSA Class
TPSA Members
Divide Overload


Eval Method

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Eval Method
TPSA Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Eval(array<Double>[]()[][]) | Evaluate the instance at numerical values of the variables.
Public method | Eval(array<array<Double>[]()[][]>[]()[][]) | Evalutes the instance at a set of numerical values of the variables.

See Also

TPSA Class
TPSA Members


Eval Method (Double[])

[image]

A Sandcastle Documented Class Library
TPSA..::..Eval Method (array<Double>[]()[][])
TPSA Class See Also Send Feedback
Evaluate the instance at numerical values of the variables.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Eval(
    params double[] args
)
Visual Basic
Public Function Eval ( _
    ParamArray args As Double() _
) As Double
Visual C++
public:
double Eval(
    ... array<double>^ args
)

Parameters

args
Type: array<System..::..Double>[]()[][]
The numerical values of the variables.

Return Value

The numerical value of the result.

Remarks

The number of arguments must equal the number of variables of the TPSA.

Exceptions

Exception | Condition
[ApplicationException] | The length of args does not equal the number of variables of the TPSA.

See Also

TPSA Class
TPSA Members
Eval Overload


Eval Method (Double[][])

[image]

A Sandcastle Documented Class Library
TPSA..::..Eval Method (array<array<Double>[]()[][]>[]()[][])
TPSA Class See Also Send Feedback
Evalutes the instance at a set of numerical values of the variables.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[] Eval(
    double[][] args
)
Visual Basic
Public Function Eval ( _
    args As Double()() _
) As Double()
Visual C++
public:
array<double>^ Eval(
    array<array<double>^>^ args
)

Parameters

args
Type: array<array<System..::..Double>[]()[][]>[]()[][]
Jagged array of sets of numerical values of the variables

Return Value

Array of values.

Exceptions

Exception | Condition
[ApplicationException] | The length of any of the elements of args does not equal the number of variables of the TPSA.

See Also

TPSA Class
TPSA Members
Eval Overload


exp Method

[image]

A Sandcastle Documented Class Library
TPSA..::..exp Method
TPSA Class See Also Send Feedback
Exponential function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA exp()
Visual Basic
Public Function exp As TPSA
Visual C++
public:
TPSA^ exp()

Return Value

The exponential of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


factorial Method

[image]

A Sandcastle Documented Class Library
TPSA..::..factorial Method
TPSA Class See Also Send Feedback
The factorial of the integer argument.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int factorial(
    int k
)
Visual Basic
Public Shared Function factorial ( _
    k As Integer _
) As Integer
Visual C++
public:
static int factorial(
    int k
)

Parameters

k
Type: System..::..Int32
The argument whose factorial is to be computed.

Return Value

The factorial

Exceptions

Exception | Condition
[OverflowException] | The factorial overflows the integer data type.

See Also

TPSA Class
TPSA Members


Filter Method

[image]

A Sandcastle Documented Class Library
TPSA..::..Filter Method
TPSA Class See Also Send Feedback
Zeros coefficients of the instance corresponding to an array of indices.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Filter(
    ref int[] terms
)
Visual Basic
Public Function Filter ( _
    ByRef terms As Integer() _
) As TPSA
Visual C++
public:
TPSA^ Filter(
    array<int>^% terms
)

Parameters

terms
Type: array<System..::..Int32>[]()[][]%
Array of indices corresponding to terms to be cleared. Can be any length

Return Value

A new TPSA object consisting of the instance with terms cleared.

See Also

TPSA Class
TPSA Members


FilterKeep Method

[image]

A Sandcastle Documented Class Library
TPSA..::..FilterKeep Method
TPSA Class See Also Send Feedback
Returns the complement of Filter.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA FilterKeep(
    ref int[] terms
)
Visual Basic
Public Function FilterKeep ( _
    ByRef terms As Integer() _
) As TPSA
Visual C++
public:
TPSA^ FilterKeep(
    array<int>^% terms
)

Parameters

terms
Type: array<System..::..Int32>[]()[][]%
The terms to keep.

Return Value

The filtered instance.

Remarks

Does not modify the instance.

See Also

TPSA Class
TPSA Members


GetTerm Method

[image]

A Sandcastle Documented Class Library
TPSA..::..GetTerm Method
TPSA Class See Also Send Feedback
Returns the coefficient of the term with variables having the exponents of the argument.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetTerm(
    ref int[] exp
)
Visual Basic
Public Function GetTerm ( _
    ByRef exp As Integer() _
) As Double
Visual C++
public:
double GetTerm(
    array<int>^% exp
)

Parameters

exp
Type: array<System..::..Int32>[]()[][]%
Array of exponents corresponding to the variables of the TPSA.

Return Value

The coefficient of the term having variables raised to the power of exp.

Exceptions

Exception | Condition
[ApplicationException] | The term was not found.

See Also

TPSA Class
TPSA Members


GetTermIndex Method

[image]

A Sandcastle Documented Class Library
TPSA..::..GetTermIndex Method
TPSA Class See Also Send Feedback
Returns the index in tps of the term with variables having the exponents of the argument.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int GetTermIndex(
    ref int[] exp
)
Visual Basic
Public Shared Function GetTermIndex ( _
    ByRef exp As Integer() _
) As Integer
Visual C++
public:
static int GetTermIndex(
    array<int>^% exp
)

Parameters

exp
Type: array<System..::..Int32>[]()[][]%
Array of exponents corresponding to the variables of the TPSA.

Return Value

[Missing <returns> documentation for "M:TPSA.TPSA.GetTermIndex(System.Int32[]@)"]

See Also

TPSA Class
TPSA Members


grad Method

[image]

A Sandcastle Documented Class Library
TPSA..::..grad Method
TPSA Class See Also Send Feedback
Returns the gradient of the instance as an array of TPSA objects.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA[] grad()
Visual Basic
Public Function grad As TPSA()
Visual C++
public:
array<TPSA^>^ grad()

Return Value

The gradient of the instance as an array TPSA objects.

Remarks

The number of TPSA objects returned is the same as the number of variables in the TPSA.

See Also

TPSA Class
TPSA Members


Init Method

[image]

A Sandcastle Documented Class Library
TPSA..::..Init Method
TPSA Class See Also Send Feedback
Initializes the class for creating TPSA objects of the given number of variable and order.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Init(
    int nvars,
    int ord,
    bool reinit = false
)
Visual Basic
Public Shared Sub Init ( _
    nvars As Integer, _
    ord As Integer, _
    Optional reinit As Boolean = False _
)
Visual C++
public:
static void Init(
    int nvars,
    int ord,
    bool reinit = false
)

Parameters

nvars
Type: System..::..Int32
Number of variables in the algebra.
ord
Type: System..::..Int32
The orderof the TPSA.
reinit (Optional)
Type: System..::..Boolean
Ensures that the class is reinitializes. If false and the same number of variables and order are specified, then nothing changes.

Remarks

See Also

TPSA Class
TPSA Members


Inverse Method

[image]

A Sandcastle Documented Class Library
TPSA..::..Inverse Method
TPSA Class See Also Send Feedback
The multiplicative inverse of the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Inverse()
Visual Basic
Public Function Inverse As TPSA
Visual C++
public:
TPSA^ Inverse()

Return Value

The inverse as a new object.

Remarks

Creates a new object.

Exceptions

Exception | Condition
[ApplicationException] | The contant term of the instance is zero.

See Also

TPSA Class
TPSA Members


log Method

[image]

A Sandcastle Documented Class Library
TPSA..::..log Method
TPSA Class See Also Send Feedback
Log function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA log()
Visual Basic
Public Function log As TPSA
Visual C++
public:
TPSA^ log()

Return Value

The logarithm of the instance.

Remarks

Creats a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


Minus Method

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Minus Method
TPSA Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Minus()()()() | Converts the instance to its arithmetic negative.
Public method | Minus(Double) | Subtracts a real value from the instance. Something like a -= operator.
Public method | Minus(TPSA) | Subtracts a TPSA object from the instance.

See Also

TPSA Class
TPSA Members


Minus Method

[image]

A Sandcastle Documented Class Library
TPSA..::..Minus Method
TPSA Class See Also Send Feedback
Converts the instance to its arithmetic negative.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Minus()
Visual Basic
Public Function Minus As TPSA
Visual C++
public:
TPSA^ Minus()

Return Value

Itself

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSA Class
TPSA Members
Minus Overload


Minus Method (Double)

[image]

A Sandcastle Documented Class Library
TPSA..::..Minus Method (Double)
TPSA Class See Also Send Feedback
Subtracts a real value from the instance. Something like a -= operator.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Minus(
    double b
)
Visual Basic
Public Function Minus ( _
    b As Double _
) As TPSA
Visual C++
public:
TPSA^ Minus(
    double b
)

Parameters

b
Type: System..::..Double
The double value to be subtracted from the instance.

Return Value

Itself.

Remarks

Does not create any new objects, but modifies the instance.

See Also

TPSA Class
TPSA Members
Minus Overload


Minus Method (TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Minus Method (TPSA)
TPSA Class See Also Send Feedback
Subtracts a TPSA object from the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Minus(
    TPSA u
)
Visual Basic
Public Function Minus ( _
    u As TPSA _
) As TPSA
Visual C++
public:
TPSA^ Minus(
    TPSA^ u
)

Parameters

u
Type: TPSA..::..TPSA
The object to be subtracted.

Return Value

Itself minus the object.

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSA Class
TPSA Members
Minus Overload


one Method

[image]

A Sandcastle Documented Class Library
TPSA..::..one Method
TPSA Class See Also Send Feedback
Returns the unit element or elements representing the variables depending on the argument.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA one(
    int i = 0
)
Visual Basic
Public Shared Function one ( _
    Optional i As Integer = 0 _
) As TPSA
Visual C++
public:
static TPSA^ one(
    int i = 0
)

Parameters

i (Optional)
Type: System..::..Int32
i=0 returns the unit element of the algebra. i>0 returns the element of the algebra corresponding to that variable.

Return Value

A new TPSA object representing the result.

See Also

TPSA Class
TPSA Members


Plus Method

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Plus Method
TPSA Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Plus(Double) | Adds a real value to the instance. Something like a += operator.
Public method | Plus(array<TPSA>[]()[][]) | Adds a TPSA object to the instance. Something like a += operator.

See Also

TPSA Class
TPSA Members


Plus Method (Double)

[image]

A Sandcastle Documented Class Library
TPSA..::..Plus Method (Double)
TPSA Class See Also Send Feedback
Adds a real value to the instance. Something like a += operator.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Plus(
    double b
)
Visual Basic
Public Function Plus ( _
    b As Double _
) As TPSA
Visual C++
public:
TPSA^ Plus(
    double b
)

Parameters

b
Type: System..::..Double
The double value to be added to the instance.

Return Value

Itself.

Remarks

Does not create any new objects, but modifies the instance.

See Also

TPSA Class
TPSA Members
Plus Overload


Plus Method (TPSA[])

[image]

A Sandcastle Documented Class Library
TPSA..::..Plus Method (array<TPSA>[]()[][])
TPSA Class See Also Send Feedback
Adds a TPSA object to the instance. Something like a += operator.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Plus(
    params TPSA[] u
)
Visual Basic
Public Function Plus ( _
    ParamArray u As TPSA() _
) As TPSA
Visual C++
public:
TPSA^ Plus(
    ... array<TPSA^>^ u
)

Parameters

u
Type: array< TPSA..::..TPSA >[]()[][]
The object to be added.

Return Value

Itself.

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSA Class
TPSA Members
Plus Overload


Power Method

[image]

A Sandcastle Documented Class Library
TPSA..::..Power Method
TPSA Class See Also Send Feedback
Raises the instance to a power and returns itself.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Power(
    int k
)
Visual Basic
Public Function Power ( _
    k As Integer _
) As TPSA
Visual C++
public:
TPSA^ Power(
    int k
)

Parameters

k
Type: System..::..Int32
The exponent.

Return Value

Itself.

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSA Class
TPSA Members


sec Method

[image]

A Sandcastle Documented Class Library
TPSA..::..sec Method
TPSA Class See Also Send Feedback
Secant function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA sec()
Visual Basic
Public Function sec As TPSA
Visual C++
public:
TPSA^ sec()

Return Value

The secant of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


sech Method

[image]

A Sandcastle Documented Class Library
TPSA..::..sech Method
TPSA Class See Also Send Feedback
Hyperbolic secant function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA sech()
Visual Basic
Public Function sech As TPSA
Visual C++
public:
TPSA^ sech()

Return Value

The hyperbolic secant of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


SetOrder Method

[image]

A Sandcastle Documented Class Library
TPSA..::..SetOrder Method
TPSA Class See Also Send Feedback
Clips terms of the instance whose order is either higher or lower than a given value, and returns a new object.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA SetOrder(
    int ord
)
Visual Basic
Public Function SetOrder ( _
    ord As Integer _
) As TPSA
Visual C++
public:
TPSA^ SetOrder(
    int ord
)

Parameters

ord
Type: System..::..Int32
The order at which to clip. If ord is positive, then terms of higher order are zeroed. If ord is negative, then terms of order lower than -ord are zeroed.

Return Value

A new object consisting of the instance clipped.

Remarks

Creates a new object.

See Also

TPSA Class
TPSA Members


sin Method

[image]

A Sandcastle Documented Class Library
TPSA..::..sin Method
TPSA Class See Also Send Feedback
Sine function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA sin()
Visual Basic
Public Function sin As TPSA
Visual C++
public:
TPSA^ sin()

Return Value

The sine of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


sinh Method

[image]

A Sandcastle Documented Class Library
TPSA..::..sinh Method
TPSA Class See Also Send Feedback
Hyperbolic sine function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA sinh()
Visual Basic
Public Function sinh As TPSA
Visual C++
public:
TPSA^ sinh()

Return Value

The hyperbolic sine of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


sort Method

[image]

A Sandcastle Documented Class Library
TPSA..::..sort Method
TPSA Class See Also Send Feedback
Sorts jagged arrays of integers.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int[][] sort(
    ref int[][] r
)
Visual Basic
Public Shared Function sort ( _
    ByRef r As Integer()() _
) As Integer()()
Visual C++
public:
static array<array<int>^>^ sort(
    array<array<int>^>^% r
)

Parameters

r
Type: array<array<System..::..Int32>[]()[][]>[]()[][]%
The array to be sorted.

Return Value

The sorted array.

See Also

TPSA Class
TPSA Members


sqrt Method

[image]

A Sandcastle Documented Class Library
TPSA..::..sqrt Method
TPSA Class See Also Send Feedback
The square root of the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA sqrt()
Visual Basic
Public Function sqrt As TPSA
Visual C++
public:
TPSA^ sqrt()

Return Value

A new object containing the square root.

Remarks

Creates one or more new objects while computing the square root.

See Also

TPSA Class
TPSA Members


tan Method

[image]

A Sandcastle Documented Class Library
TPSA..::..tan Method
TPSA Class See Also Send Feedback
Tangent function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA tan()
Visual Basic
Public Function tan As TPSA
Visual C++
public:
TPSA^ tan()

Return Value

The tangent of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


tanh Method

[image]

A Sandcastle Documented Class Library
TPSA..::..tanh Method
TPSA Class See Also Send Feedback
Hyperbolic tangent function.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA tanh()
Visual Basic
Public Function tanh As TPSA
Visual C++
public:
TPSA^ tanh()

Return Value

The hyperbolic tangent of the instance.

Remarks

Creates a new object and does not modify the instance.

See Also

TPSA Class
TPSA Members


Times Method

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Times Method
TPSA Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Times(Double) | Multiplies the instance by a double.
Public method | Times(array<TPSA>[]()[][]) | Multiplies the instance by a TPSA object and returns itself.

See Also

TPSA Class
TPSA Members


Times Method (Double)

[image]

A Sandcastle Documented Class Library
TPSA..::..Times Method (Double)
TPSA Class See Also Send Feedback
Multiplies the instance by a double.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Times(
    double b
)
Visual Basic
Public Function Times ( _
    b As Double _
) As TPSA
Visual C++
public:
TPSA^ Times(
    double b
)

Parameters

b
Type: System..::..Double
The real value.

Return Value

Itself.

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSA Class
TPSA Members
Times Overload


Times Method (TPSA[])

[image]

A Sandcastle Documented Class Library
TPSA..::..Times Method (array<TPSA>[]()[][])
TPSA Class See Also Send Feedback
Multiplies the instance by a TPSA object and returns itself.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSA Times(
    params TPSA[] u
)
Visual Basic
Public Function Times ( _
    ParamArray u As TPSA() _
) As TPSA
Visual C++
public:
TPSA^ Times(
    ... array<TPSA^>^ u
)

Parameters

u
Type: array< TPSA..::..TPSA >[]()[][]
The object the instance is to be multiplied by.

Return Value

Itself.

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSA Class
TPSA Members
Times Overload


ToString Method

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..ToString Method
TPSA Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(Double, String) | Returns a string representation of the instance.

See Also

TPSA Class
TPSA Members


ToString Method (Double, String)

[image]

A Sandcastle Documented Class Library
TPSA..::..ToString Method (Double, String)
TPSA Class See Also Send Feedback
Returns a string representation of the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ToString(
    double eps = 1E-14,
    string formatstring = "G"
)
Visual Basic
Public Function ToString ( _
    Optional eps As Double = 1E-14, _
    Optional formatstring As String = "G" _
) As String
Visual C++
public:
String^ ToString(
    double eps = 1E-14,
    String^ formatstring = L"G"
)

Parameters

eps (Optional)
Type: System..::..Double
Coeffients having values smaller than this argument are clipped to zero.
formatstring (Optional)
Type: System..::..String
A format string.

Return Value

The string representation.

Remarks

See Also

TPSA Class
TPSA Members
ToString Overload


TPSA Operators

[image] [image]

A Sandcastle Documented Class Library
TPSA Operators
TPSA Class See Also Send Feedback

The TPSA type exposes the following members.

Operators

Name | Description
Addition(Double, TPSA) | Adds a double to a TPSA object.
Addition(TPSA, Double) | The addition operator that acts on two instances.
Addition(TPSA, TPSA) | Overloaded addition operator for two TPSA objects.
Division(Double, TPSA) | Divides a double by a TPSA object.
Division(TPSA, Double) | Divides a TPSA object by a double.
Division(TPSA, TPSA) | Divide two TPSA objects.
Exponent | Raises the instance to a power.
Multiply(Double, TPSA) | Multiplies a TPSA object by a double.
Multiply(TPSA, Double) | Overloade multiply a TPSA object by a double.
Multiply(TPSA, TPSA) | Multiply two TPSA objects.
Subtraction(Double, TPSA) | Overloaded subtraction operator with one argument being a double.
Subtraction(TPSA, Double) | The subtraction operator that acts on two instances.
Subtraction(TPSA, TPSA) | Overloaded subtraction operator for two TPSA objects.
UnaryNegation | The arithmetic negative of the instance.

See Also

TPSA Class


Addition Operator

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Addition Operator
TPSA Class See Also Send Feedback

Overload List

Name | Description
Addition(Double, TPSA) | Adds a double to a TPSA object.
Addition(TPSA, Double) | The addition operator that acts on two instances.
Addition(TPSA, TPSA) | Overloaded addition operator for two TPSA objects.

See Also

TPSA Class
TPSA Members


Addition Operator (Double, TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Addition Operator (Double, TPSA)
TPSA Class See Also Send Feedback
Adds a double to a TPSA object.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator +(
    double b,
    TPSA a
)
Visual Basic
Public Shared Operator + ( _
    b As Double, _
    a As TPSA _
) As TPSA
Visual C++
public:
static TPSA^ operator +(
    double b,
    TPSA^ a
)

Parameters

b
Type: System..::..Double
The double operand.
a
Type: TPSA..::..TPSA
The TPSA operand.

Return Value

The sum.

See Also

TPSA Class
TPSA Members
Addition Overload


Addition Operator (TPSA, Double)

[image]

A Sandcastle Documented Class Library
TPSA..::..Addition Operator (TPSA, Double)
TPSA Class See Also Send Feedback
The addition operator that acts on two instances.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator +(
    TPSA a,
    double b
)
Visual Basic
Public Shared Operator + ( _
    a As TPSA, _
    b As Double _
) As TPSA
Visual C++
public:
static TPSA^ operator +(
    TPSA^ a,
    double b
)

Parameters

a
Type: TPSA..::..TPSA
The first operand.
b
Type: System..::..Double
The second operand.

Return Value

A new instance containing the sum.

See Also

TPSA Class
TPSA Members
Addition Overload


Addition Operator (TPSA, TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Addition Operator (TPSA, TPSA)
TPSA Class See Also Send Feedback
Overloaded addition operator for two TPSA objects.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator +(
    TPSA a,
    TPSA b
)
Visual Basic
Public Shared Operator + ( _
    a As TPSA, _
    b As TPSA _
) As TPSA
Visual C++
public:
static TPSA^ operator +(
    TPSA^ a,
    TPSA^ b
)

Parameters

a
Type: TPSA..::..TPSA
The first operand.
b
Type: TPSA..::..TPSA
The second operand.

Return Value

A new object containing the sum.

See Also

TPSA Class
TPSA Members
Addition Overload


Division Operator

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Division Operator
TPSA Class See Also Send Feedback

Overload List

Name | Description
Division(Double, TPSA) | Divides a double by a TPSA object.
Division(TPSA, Double) | Divides a TPSA object by a double.
Division(TPSA, TPSA) | Divide two TPSA objects.

See Also

TPSA Class
TPSA Members


Division Operator (Double, TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Division Operator (Double, TPSA)
TPSA Class See Also Send Feedback
Divides a double by a TPSA object.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator /(
    double b,
    TPSA a
)
Visual Basic
Public Shared Operator / ( _
    b As Double, _
    a As TPSA _
) As TPSA
Visual C++
public:
static TPSA^ operator /(
    double b,
    TPSA^ a
)

Parameters

b
Type: System..::..Double
The double argument.
a
Type: TPSA..::..TPSA
The TPSA argument.

Return Value

The new product object.

Remarks

Creates a new object.

See Also

TPSA Class
TPSA Members
Division Overload


Division Operator (TPSA, Double)

[image]

A Sandcastle Documented Class Library
TPSA..::..Division Operator (TPSA, Double)
TPSA Class See Also Send Feedback
Divides a TPSA object by a double.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator /(
    TPSA a,
    double b
)
Visual Basic
Public Shared Operator / ( _
    a As TPSA, _
    b As Double _
) As TPSA
Visual C++
public:
static TPSA^ operator /(
    TPSA^ a,
    double b
)

Parameters

a
Type: TPSA..::..TPSA
The TPSA object.
b
Type: System..::..Double
The real (double) value.

Return Value

A new object consisting of the product.

Remarks

Creates a new object.

See Also

TPSA Class
TPSA Members
Division Overload


Division Operator (TPSA, TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Division Operator (TPSA, TPSA)
TPSA Class See Also Send Feedback
Divide two TPSA objects.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator /(
    TPSA a,
    TPSA b
)
Visual Basic
Public Shared Operator / ( _
    a As TPSA, _
    b As TPSA _
) As TPSA
Visual C++
public:
static TPSA^ operator /(
    TPSA^ a,
    TPSA^ b
)

Parameters

a
Type: TPSA..::..TPSA
The first operand.
b
Type: TPSA..::..TPSA
The second operand.

Return Value

A new object containing the ratio.

Remarks

Creates a new object.

See Also

TPSA Class
TPSA Members
Division Overload


Exponent Operator

[image]

A Sandcastle Documented Class Library
TPSA..::..Exponent Operator
TPSA Class See Also Send Feedback
Raises the instance to a power.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
C# does not support this operator.
Visual Basic
Public Shared Operator ^ ( _
    a As TPSA, _
    k As Integer _
) As TPSA
Visual C++
Visual C++ does not support this operator.

Parameters

a
Type: TPSA..::..TPSA
The TPSA object.
k
Type: System..::..Int32
The exponent.

Return Value

The power.

Remarks

Creates a new object.

See Also

TPSA Class
TPSA Members


Multiply Operator

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Multiply Operator
TPSA Class See Also Send Feedback

Overload List

Name | Description
Multiply(Double, TPSA) | Multiplies a TPSA object by a double.
Multiply(TPSA, Double) | Overloade multiply a TPSA object by a double.
Multiply(TPSA, TPSA) | Multiply two TPSA objects.

See Also

TPSA Class
TPSA Members


Multiply Operator (Double, TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Multiply Operator (Double, TPSA)
TPSA Class See Also Send Feedback
Multiplies a TPSA object by a double.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator *(
    double b,
    TPSA a
)
Visual Basic
Public Shared Operator * ( _
    b As Double, _
    a As TPSA _
) As TPSA
Visual C++
public:
static TPSA^ operator *(
    double b,
    TPSA^ a
)

Parameters

b
Type: System..::..Double
The double argument.
a
Type: TPSA..::..TPSA
The TPSA argument.

Return Value

A new product object.

Remarks

Creates a new object.

See Also

TPSA Class
TPSA Members
Multiply Overload


Multiply Operator (TPSA, Double)

[image]

A Sandcastle Documented Class Library
TPSA..::..Multiply Operator (TPSA, Double)
TPSA Class See Also Send Feedback
Overloade multiply a TPSA object by a double.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator *(
    TPSA a,
    double b
)
Visual Basic
Public Shared Operator * ( _
    a As TPSA, _
    b As Double _
) As TPSA
Visual C++
public:
static TPSA^ operator *(
    TPSA^ a,
    double b
)

Parameters

a
Type: TPSA..::..TPSA
The TPSA operand.
b
Type: System..::..Double
The real operand.

Return Value

A new product object.

Remarks

Creates a new object.

See Also

TPSA Class
TPSA Members
Multiply Overload


Multiply Operator (TPSA, TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Multiply Operator (TPSA, TPSA)
TPSA Class See Also Send Feedback
Multiply two TPSA objects.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator *(
    TPSA a,
    TPSA b
)
Visual Basic
Public Shared Operator * ( _
    a As TPSA, _
    b As TPSA _
) As TPSA
Visual C++
public:
static TPSA^ operator *(
    TPSA^ a,
    TPSA^ b
)

Parameters

a
Type: TPSA..::..TPSA
The first multiplicand.
b
Type: TPSA..::..TPSA
The second multiplicand.

Return Value

A new object containing the product.

Remarks

Creates a new object.

See Also

TPSA Class
TPSA Members
Multiply Overload


Subtraction Operator

[image] [image]

A Sandcastle Documented Class Library
TPSA..::..Subtraction Operator
TPSA Class See Also Send Feedback

Overload List

Name | Description
Subtraction(Double, TPSA) | Overloaded subtraction operator with one argument being a double.
Subtraction(TPSA, Double) | The subtraction operator that acts on two instances.
Subtraction(TPSA, TPSA) | Overloaded subtraction operator for two TPSA objects.

See Also

TPSA Class
TPSA Members


Subtraction Operator (Double, TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Subtraction Operator (Double, TPSA)
TPSA Class See Also Send Feedback
Overloaded subtraction operator with one argument being a double.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator -(
    double b,
    TPSA a
)
Visual Basic
Public Shared Operator - ( _
    b As Double, _
    a As TPSA _
) As TPSA
Visual C++
public:
static TPSA^ operator -(
    double b,
    TPSA^ a
)

Parameters

b
Type: System..::..Double
The real argument.
a
Type: TPSA..::..TPSA
The TPSA argument subtracted from b.

Return Value

A new b - a.

Remarks

Creates a new object.

See Also

TPSA Class
TPSA Members
Subtraction Overload


Subtraction Operator (TPSA, Double)

[image]

A Sandcastle Documented Class Library
TPSA..::..Subtraction Operator (TPSA, Double)
TPSA Class See Also Send Feedback
The subtraction operator that acts on two instances.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator -(
    TPSA a,
    double b
)
Visual Basic
Public Shared Operator - ( _
    a As TPSA, _
    b As Double _
) As TPSA
Visual C++
public:
static TPSA^ operator -(
    TPSA^ a,
    double b
)

Parameters

a
Type: TPSA..::..TPSA
The first operand.
b
Type: System..::..Double
The second operand.

Return Value

A new instance containing the difference.

See Also

TPSA Class
TPSA Members
Subtraction Overload


Subtraction Operator (TPSA, TPSA)

[image]

A Sandcastle Documented Class Library
TPSA..::..Subtraction Operator (TPSA, TPSA)
TPSA Class See Also Send Feedback
Overloaded subtraction operator for two TPSA objects.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator -(
    TPSA a,
    TPSA b
)
Visual Basic
Public Shared Operator - ( _
    a As TPSA, _
    b As TPSA _
) As TPSA
Visual C++
public:
static TPSA^ operator -(
    TPSA^ a,
    TPSA^ b
)

Parameters

a
Type: TPSA..::..TPSA
The first operand.
b
Type: TPSA..::..TPSA
The second operand.

Return Value

A new object containing the difference.

See Also

TPSA Class
TPSA Members
Subtraction Overload


UnaryNegation Operator

[image]

A Sandcastle Documented Class Library
TPSA..::..UnaryNegation Operator
TPSA Class See Also Send Feedback
The arithmetic negative of the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA operator -(
    TPSA a
)
Visual Basic
Public Shared Operator - ( _
    a As TPSA _
) As TPSA
Visual C++
public:
static TPSA^ operator -(
    TPSA^ a
)

Parameters

a
Type: TPSA..::..TPSA
The object whose negative is to be returned.

Return Value

The new TPSA object.

See Also

TPSA Class
TPSA Members


TPSA Properties

[image] [image]

A Sandcastle Documented Class Library
TPSA Properties
TPSA Class See Also Send Feedback

The TPSA type exposes the following members.

Properties

Name | Description
TPSAOrder | Order of the TPSA.
TPSATerms | The number of terms in the TPSA.
TPSAVariables | The number of variables in the TPSA.

See Also

TPSA Class


TPSAOrder Property

[image]

A Sandcastle Documented Class Library
TPSA..::..TPSAOrder Property
TPSA Class See Also Send Feedback
Order of the TPSA.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int TPSAOrder { get; }
Visual Basic
Public Shared ReadOnly Property TPSAOrder As Integer
    Get
Visual C++
public:
static property int TPSAOrder {
    int get ();
}

Remarks

Defined when the class is initialized by Init.

See Also

TPSA Class
TPSA Members


TPSATerms Property

[image]

A Sandcastle Documented Class Library
TPSA..::..TPSATerms Property
TPSA Class See Also Send Feedback
The number of terms in the TPSA.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int TPSATerms { get; }
Visual Basic
Public Shared ReadOnly Property TPSATerms As Integer
    Get
Visual C++
public:
static property int TPSATerms {
    int get ();
}

Remarks

This number is derived from TPSAVariables and TPSAOrder.

See Also

TPSA Class
TPSA Members


TPSAVariables Property

[image]

A Sandcastle Documented Class Library
TPSA..::..TPSAVariables Property
TPSA Class See Also Send Feedback
The number of variables in the TPSA.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int TPSAVariables { get; }
Visual Basic
Public Shared ReadOnly Property TPSAVariables As Integer
    Get
Visual C++
public:
static property int TPSAVariables {
    int get ();
}

Remarks

Defined when the class is initialized by Init.

See Also

TPSA Class
TPSA Members


TPSAMaps Class

[image]

A Sandcastle Documented Class Library
TPSAMaps Class
Members See Also Send Feedback
TPSAMaps models maps (coordinate transformations) using the algebra of truncated power series (polynomials of fixed maximum degree).

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TPSAMaps
Visual Basic
Public Class TPSAMaps
Visual C++
public ref class TPSAMaps

Remarks

Essentially, a TPSAMaps object is a collection of TPSA objects, each of which maps the coordinate variables to the variable corresponding to that object. Together they determine a coordinate transformation. For this reason the number of TPSA objects in the instance must equal the number of variables.

Inheritance Hierarchy

System..::..Object
TPSA..::..TPSAMaps

See Also

TPSAMaps Members


TPSAMaps Members

[image] [image]

A Sandcastle Documented Class Library
TPSAMaps Members
TPSAMaps Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TPSAMaps type exposes the following members.

Constructors

 | Name | Description
Public method | TPSAMaps(array<TPSA>[]()[][]) | Creates a new TPSAMaps object from a list of TPSA objects.
Public method | TPSAMaps(TPSAMaps..::..Create) | Creates a new TPSAMaps object with or without actually instantiating the components of the map.

Methods

 | Name | Description
Public method | Clear | Clears the instance's map.
Public method | Clone | Creates a clone of the instance.
Public method | comp | The composition of the instance and another map. Synonym of Compose.
Public method | Compose | The composition of the instance and another map.
Public method | Copy | Copies the TPSAMaps argument to the instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Eval(array<Double>[]()[][]) | Evaluates the instance map at a point.
Public method | Eval(array<array<Double>[]()[][]>[]()[][]) | Evaluate instance map at a set of points.
Public method | Filter | Set to zero specific terms of a map.
Public method | FilterKeep | Set to zero all but a specific set of terms of a map.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Init | Initializes the class.
Public method | Inverse | Computes the map inverse of the instance.
Public method | LieBracket(TPSAMaps) | The Lie bracket of two maps.
 | LieBracket(TPSAMaps, TPSAMaps) | The Lie bracket of two maps.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus | Subtracts a map from the instance.
Public method | Plus | Adds a map to the instance.
Public method | SetOrder | Clips terms of the instance whose order is either higher or lower than a given value, and returns a new object.
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(Double, String) | Computes a string representation of the map.

Operators

Name | Description
Addition | Add two TPSAMap objects.
Subtraction | The difference between two maps.
UnaryNegation | Overloaded operator that computes the component-by-component arithmetic negative of the argument.

Fields

Name | Description
Id | Identity map.
zero | The zero map.

Properties

Name | Description
TPSAOrder | Order of the underlying TPSA.
TPSATerms | Number of terms of the underlying TPSA.
TPSAVariables | Number of variables in the underlying TPSA.

See Also

TPSAMaps Class


TPSAMaps Constructor

[image] [image]

A Sandcastle Documented Class Library
TPSAMaps Constructor
TPSAMaps Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TPSAMaps(array<TPSA>[]()[][]) | Creates a new TPSAMaps object from a list of TPSA objects.
Public method | TPSAMaps(TPSAMaps..::..Create) | Creates a new TPSAMaps object with or without actually instantiating the components of the map.

See Also

TPSAMaps Class
TPSAMaps Members


TPSAMaps Constructor (TPSA[])

[image]

A Sandcastle Documented Class Library
TPSAMaps Constructor (array<TPSA>[]()[][])
TPSAMaps Class See Also Send Feedback
Creates a new TPSAMaps object from a list of TPSA objects.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps(
    params TPSA[] t
)
Visual Basic
Public Sub New ( _
    ParamArray t As TPSA() _
)
Visual C++
public:
TPSAMaps(
    ... array<TPSA^>^ t
)

Parameters

t
Type: array< TPSA..::..TPSA >[]()[][]
The list of TPSA objects.

Remarks

The elements of the argument are assigned element by element to the components of the new map.

Exceptions

Exception | Condition
[ApplicationException] | The number of elements in t is not the same as the number of variables in the TPSA.

See Also

TPSAMaps Class
TPSAMaps Members
TPSAMaps Overload


TPSAMaps Constructor (TPSAMaps.Create)

[image]

A Sandcastle Documented Class Library
TPSAMaps Constructor (TPSAMaps..::..Create)
TPSAMaps Class See Also Send Feedback
Creates a new TPSAMaps object with or without actually instantiating the components of the map.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps(
    TPSAMaps..::..Create create = TPSAMaps..::..Create.Instantiate
)
Visual Basic
Public Sub New ( _
    Optional create As TPSAMaps..::..Create = TPSAMaps..::..Create.Instantiate _
)
Visual C++
public:
TPSAMaps(
    TPSAMaps..::..Create create = TPSAMaps..::..Create::Instantiate
)

Parameters

create (Optional)
Type: TPSA..::..TPSAMaps..::..Create
Whether to instantiate the components of the map.

Remarks

At times it is expedient to create the TPSAMaps object but not instantiate the TPSA components because they are shortly to be redefined in another step.

See Also

TPSAMaps Class
TPSAMaps Members
TPSAMaps Overload


TPSAMaps Fields

[image] [image]

A Sandcastle Documented Class Library
TPSAMaps Fields
TPSAMaps Class See Also Send Feedback

The TPSAMaps type exposes the following members.

Fields

Name | Description
Id | Identity map.
zero | The zero map.

See Also

TPSAMaps Class


Id Field

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Id Field
TPSAMaps Class See Also Send Feedback
Identity map.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSAMaps Id
Visual Basic
Public Shared Id As TPSAMaps
Visual C++
public:
static TPSAMaps^ Id

Remarks

Defined at the time the class is initialized via Init.

See Also

TPSAMaps Class
TPSAMaps Members


zero Field

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..zero Field
TPSAMaps Class See Also Send Feedback
The zero map.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSA zero
Visual Basic
Public Shared zero As TPSA
Visual C++
public:
static TPSA^ zero

Remarks

Defined at the time the class is initialized via Init.

See Also

TPSAMaps Class
TPSAMaps Members


TPSAMaps Methods

[image] [image]

A Sandcastle Documented Class Library
TPSAMaps Methods
TPSAMaps Class See Also Send Feedback

The TPSAMaps type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears the instance's map.
Public method | Clone | Creates a clone of the instance.
Public method | comp | The composition of the instance and another map. Synonym of Compose.
Public method | Compose | The composition of the instance and another map.
Public method | Copy | Copies the TPSAMaps argument to the instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Eval(array<Double>[]()[][]) | Evaluates the instance map at a point.
Public method | Eval(array<array<Double>[]()[][]>[]()[][]) | Evaluate instance map at a set of points.
Public method | Filter | Set to zero specific terms of a map.
Public method | FilterKeep | Set to zero all but a specific set of terms of a map.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Init | Initializes the class.
Public method | Inverse | Computes the map inverse of the instance.
Public method | LieBracket(TPSAMaps) | The Lie bracket of two maps.
 | LieBracket(TPSAMaps, TPSAMaps) | The Lie bracket of two maps.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus | Subtracts a map from the instance.
Public method | Plus | Adds a map to the instance.
Public method | SetOrder | Clips terms of the instance whose order is either higher or lower than a given value, and returns a new object.
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(Double, String) | Computes a string representation of the map.

See Also

TPSAMaps Class


Clear Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Clear Method
TPSAMaps Class See Also Send Feedback
Clears the instance's map.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps Clear()
Visual Basic
Public Function Clear As TPSAMaps
Visual C++
public:
TPSAMaps^ Clear()

Return Value

Itself.

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSAMaps Class
TPSAMaps Members


Clone Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Clone Method
TPSAMaps Class See Also Send Feedback
Creates a clone of the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps Clone()
Visual Basic
Public Function Clone As TPSAMaps
Visual C++
public:
TPSAMaps^ Clone()

Return Value

The clone.

See Also

TPSAMaps Class
TPSAMaps Members


comp Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..comp Method
TPSAMaps Class See Also Send Feedback
The composition of the instance and another map. Synonym of Compose.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps comp(
    ref TPSAMaps a
)
Visual Basic
Public Function comp ( _
    ByRef a As TPSAMaps _
) As TPSAMaps
Visual C++
public:
TPSAMaps^ comp(
    TPSAMaps^% a
)

Parameters

a
Type: TPSA..::..TPSAMaps %
The instance is composed with this argument.

Return Value

The map that is the composition of the two maps.

Remarks

Creates a new object. The instance is not modified.

See Also

TPSAMaps Class
TPSAMaps Members


Compose Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Compose Method
TPSAMaps Class See Also Send Feedback
The composition of the instance and another map.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps Compose(
    ref TPSAMaps a
)
Visual Basic
Public Function Compose ( _
    ByRef a As TPSAMaps _
) As TPSAMaps
Visual C++
public:
TPSAMaps^ Compose(
    TPSAMaps^% a
)

Parameters

a
Type: TPSA..::..TPSAMaps %
The instance is composed with this argument.

Return Value

The map that is the composition of the two maps.

Remarks

Creates a new object. The instance is not modified.

See Also

TPSAMaps Class
TPSAMaps Members


Copy Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Copy Method
TPSAMaps Class See Also Send Feedback
Copies the TPSAMaps argument to the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Copy(
    ref TPSAMaps x
)
Visual Basic
Public Sub Copy ( _
    ByRef x As TPSAMaps _
)
Visual C++
public:
void Copy(
    TPSAMaps^% x
)

Parameters

x
Type: TPSA..::..TPSAMaps %
The TPSAMaps to be copied to the instance.

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSAMaps Class
TPSAMaps Members


Eval Method

[image] [image]

A Sandcastle Documented Class Library
TPSAMaps..::..Eval Method
TPSAMaps Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Eval(array<Double>[]()[][]) | Evaluates the instance map at a point.
Public method | Eval(array<array<Double>[]()[][]>[]()[][]) | Evaluate instance map at a set of points.

See Also

TPSAMaps Class
TPSAMaps Members


Eval Method (Double[])

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Eval Method (array<Double>[]()[][])
TPSAMaps Class See Also Send Feedback
Evaluates the instance map at a point.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[] Eval(
    params double[] args
)
Visual Basic
Public Function Eval ( _
    ParamArray args As Double() _
) As Double()
Visual C++
public:
array<double>^ Eval(
    ... array<double>^ args
)

Parameters

args
Type: array<System..::..Double>[]()[][]
A ParamArray of real arguments.

Return Value

A point result (a list of reals).

Exceptions

Exception | Condition
[ApplicationException] | The number of arguments is not equal to the number of variables in the algebra.

See Also

TPSAMaps Class
TPSAMaps Members
Eval Overload


Eval Method (Double[][])

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Eval Method (array<array<Double>[]()[][]>[]()[][])
TPSAMaps Class See Also Send Feedback
Evaluate instance map at a set of points.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[][] Eval(
    double[][] args
)
Visual Basic
Public Function Eval ( _
    args As Double()() _
) As Double()()
Visual C++
public:
array<array<double>^>^ Eval(
    array<array<double>^>^ args
)

Parameters

args
Type: array<array<System..::..Double>[]()[][]>[]()[][]
A set of points in a jagged array.

Return Value

A list of points in a jagged array.

Exceptions

Exception | Condition
[ApplicationException] | The number of arguments in any of the points is not equal to the number of variables in the algebra.

See Also

TPSAMaps Class
TPSAMaps Members
Eval Overload


Filter Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Filter Method
TPSAMaps Class See Also Send Feedback
Set to zero specific terms of a map.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps Filter(
    ref int[][] terms
)
Visual Basic
Public Function Filter ( _
    ByRef terms As Integer()() _
) As TPSAMaps
Visual C++
public:
TPSAMaps^ Filter(
    array<array<int>^>^% terms
)

Parameters

terms
Type: array<array<System..::..Int32>[]()[][]>[]()[][]%
A jagged array of indices of terms to be set to zero. For v variables, each of the v arrays of indices is applied to the corresponding TPSA object of the map.

Return Value

The filtered map.

Remarks

Creates a new TPSAMaps object.

Exceptions

Exception | Condition
[ApplicationException] | The number of arguments in any of the points is not equal to the number of variables in the algebra.

See Also

TPSAMaps Class
TPSAMaps Members


FilterKeep Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..FilterKeep Method
TPSAMaps Class See Also Send Feedback
Set to zero all but a specific set of terms of a map.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps FilterKeep(
    ref int[][] terms
)
Visual Basic
Public Function FilterKeep ( _
    ByRef terms As Integer()() _
) As TPSAMaps
Visual C++
public:
TPSAMaps^ FilterKeep(
    array<array<int>^>^% terms
)

Parameters

terms
Type: array<array<System..::..Int32>[]()[][]>[]()[][]%
A jagged array of indices of terms not to be set to zero. For v variables, each of the v arrays of indices is appled to the corresponding TPSA object of the map.

Return Value

The filtered map.

Remarks

Creates a new TPSAMaps object.

Exceptions

Exception | Condition
[ApplicationException] | The number of arguments in any of the points is not equal to the number of variables in the algebra.

See Also

TPSAMaps Class
TPSAMaps Members


Init Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Init Method
TPSAMaps Class See Also Send Feedback
Initializes the class.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Init(
    int vars,
    int ord
)
Visual Basic
Public Shared Sub Init ( _
    vars As Integer, _
    ord As Integer _
)
Visual C++
public:
static void Init(
    int vars,
    int ord
)

Parameters

vars
Type: System..::..Int32
The number of variables in the new algebra.
ord
Type: System..::..Int32
The order of the maps in the algebra.

Remarks

Sets the number of variables and order of the underlying TPSA. Also defines shared elements representing the zero map and the identity map.

See Also

TPSAMaps Class
TPSAMaps Members


Inverse Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Inverse Method
TPSAMaps Class See Also Send Feedback
Computes the map inverse of the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps Inverse()
Visual Basic
Public Function Inverse As TPSAMaps
Visual C++
public:
TPSAMaps^ Inverse()

Return Value

The inverse map.

Remarks

The map inverse is related to the concept of reversion of series. See Berz (1991) for an explanation of the algorithm.

See Also

TPSAMaps Class
TPSAMaps Members


LieBracket Method

[image] [image]

A Sandcastle Documented Class Library
TPSAMaps..::..LieBracket Method
TPSAMaps Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LieBracket(TPSAMaps) | The Lie bracket of two maps.
 | LieBracket(TPSAMaps, TPSAMaps) | The Lie bracket of two maps.

See Also

TPSAMaps Class
TPSAMaps Members


LieBracket Method (TPSAMaps)

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..LieBracket Method (TPSAMaps)
TPSAMaps Class See Also Send Feedback
The Lie bracket of two maps.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps LieBracket(
    TPSAMaps b
)
Visual Basic
Public Function LieBracket ( _
    b As TPSAMaps _
) As TPSAMaps
Visual C++
public:
TPSAMaps^ LieBracket(
    TPSAMaps^ b
)

Parameters

b
Type: TPSA..::..TPSAMaps
The Lie bracket of the instance and this argument is computed.

Return Value

Instance method of the Lie bracket (instance composed with b - b composed with the instance).

See Also

TPSAMaps Class
TPSAMaps Members
LieBracket Overload


LieBracket Method (TPSAMaps, TPSAMaps)

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..LieBracket Method (TPSAMaps, TPSAMaps)
TPSAMaps Class See Also Send Feedback
The Lie bracket of two maps.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSAMaps LieBracket(
    TPSAMaps a,
    TPSAMaps b
)
Visual Basic
Public Shared Function LieBracket ( _
    a As TPSAMaps, _
    b As TPSAMaps _
) As TPSAMaps
Visual C++
public:
static TPSAMaps^ LieBracket(
    TPSAMaps^ a,
    TPSAMaps^ b
)

Parameters

a
Type: TPSA..::..TPSAMaps
The first argument.
b
Type: TPSA..::..TPSAMaps
The second argument

Return Value

Shared version of the Lie bracket (a composed with b - b composed with a).

See Also

TPSAMaps Class
TPSAMaps Members
LieBracket Overload


Minus Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Minus Method
TPSAMaps Class See Also Send Feedback
Subtracts a map from the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps Minus(
    TPSAMaps a
)
Visual Basic
Public Function Minus ( _
    a As TPSAMaps _
) As TPSAMaps
Visual C++
public:
TPSAMaps^ Minus(
    TPSAMaps^ a
)

Parameters

a
Type: TPSA..::..TPSAMaps
The map to be subtracted.

Return Value

Itself

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSAMaps Class
TPSAMaps Members


Plus Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Plus Method
TPSAMaps Class See Also Send Feedback
Adds a map to the instance.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps Plus(
    TPSAMaps a
)
Visual Basic
Public Function Plus ( _
    a As TPSAMaps _
) As TPSAMaps
Visual C++
public:
TPSAMaps^ Plus(
    TPSAMaps^ a
)

Parameters

a
Type: TPSA..::..TPSAMaps
The map to be added.

Return Value

Itself

Remarks

Does not create a new object, but modifies the instance.

See Also

TPSAMaps Class
TPSAMaps Members


SetOrder Method

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..SetOrder Method
TPSAMaps Class See Also Send Feedback
Clips terms of the instance whose order is either higher or lower than a given value, and returns a new object.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TPSAMaps SetOrder(
    int k
)
Visual Basic
Public Function SetOrder ( _
    k As Integer _
) As TPSAMaps
Visual C++
public:
TPSAMaps^ SetOrder(
    int k
)

Parameters

k
Type: System..::..Int32
The order at which to clip. If ord is positive, then terms of higher order are zeroed. If k is negative, then terms of order lower than -k are zeroed.

Return Value

A new object consisting of the instance clipped.

Remarks

Creates a new object, and does not modify the instance.

See Also

TPSAMaps Class
TPSAMaps Members


ToString Method

[image] [image]

A Sandcastle Documented Class Library
TPSAMaps..::..ToString Method
TPSAMaps Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(Double, String) | Computes a string representation of the map.

See Also

TPSAMaps Class
TPSAMaps Members


ToString Method (Double, String)

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..ToString Method (Double, String)
TPSAMaps Class See Also Send Feedback
Computes a string representation of the map.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ToString(
    double eps = 1E-14,
    string formatstring = "G"
)
Visual Basic
Public Function ToString ( _
    Optional eps As Double = 1E-14, _
    Optional formatstring As String = "G" _
) As String
Visual C++
public:
String^ ToString(
    double eps = 1E-14,
    String^ formatstring = L"G"
)

Parameters

eps (Optional)
Type: System..::..Double
Coefficients that are smaller than this parameter are clipped to zero prior to conversion to a string.
formatstring (Optional)
Type: System..::..String
A Visual Basic format string used to set the format of the string representation of reals.

Return Value

The string representation.

Remarks

The representation has a multi-line matrix-like appearance.

See Also

TPSAMaps Class
TPSAMaps Members
ToString Overload


TPSAMaps Operators

[image] [image]

A Sandcastle Documented Class Library
TPSAMaps Operators
TPSAMaps Class See Also Send Feedback

The TPSAMaps type exposes the following members.

Operators

Name | Description
Addition | Add two TPSAMap objects.
Subtraction | The difference between two maps.
UnaryNegation | Overloaded operator that computes the component-by-component arithmetic negative of the argument.

See Also

TPSAMaps Class


Addition Operator

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Addition Operator
TPSAMaps Class See Also Send Feedback
Add two TPSAMap objects.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSAMaps operator +(
    TPSAMaps a,
    TPSAMaps b
)
Visual Basic
Public Shared Operator + ( _
    a As TPSAMaps, _
    b As TPSAMaps _
) As TPSAMaps
Visual C++
public:
static TPSAMaps^ operator +(
    TPSAMaps^ a,
    TPSAMaps^ b
)

Parameters

a
Type: TPSA..::..TPSAMaps
First argument.
b
Type: TPSA..::..TPSAMaps
Second rgument.

Return Value

The sum.

See Also

TPSAMaps Class
TPSAMaps Members


Subtraction Operator

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Subtraction Operator
TPSAMaps Class See Also Send Feedback
The difference between two maps.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSAMaps operator -(
    TPSAMaps a,
    TPSAMaps b
)
Visual Basic
Public Shared Operator - ( _
    a As TPSAMaps, _
    b As TPSAMaps _
) As TPSAMaps
Visual C++
public:
static TPSAMaps^ operator -(
    TPSAMaps^ a,
    TPSAMaps^ b
)

Parameters

a
Type: TPSA..::..TPSAMaps
The first argument.
b
Type: TPSA..::..TPSAMaps
The second argument.

Return Value

The difference.

See Also

TPSAMaps Class
TPSAMaps Members


UnaryNegation Operator

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..UnaryNegation Operator
TPSAMaps Class See Also Send Feedback
Overloaded operator that computes the component-by-component arithmetic negative of the argument.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TPSAMaps operator -(
    TPSAMaps a
)
Visual Basic
Public Shared Operator - ( _
    a As TPSAMaps _
) As TPSAMaps
Visual C++
public:
static TPSAMaps^ operator -(
    TPSAMaps^ a
)

Parameters

a
Type: TPSA..::..TPSAMaps
The TPSAMaps object whose negative is computed.

Return Value

The arithmetic negative.

See Also

TPSAMaps Class
TPSAMaps Members


TPSAMaps Properties

[image] [image]

A Sandcastle Documented Class Library
TPSAMaps Properties
TPSAMaps Class See Also Send Feedback

The TPSAMaps type exposes the following members.

Properties

Name | Description
TPSAOrder | Order of the underlying TPSA.
TPSATerms | Number of terms of the underlying TPSA.
TPSAVariables | Number of variables in the underlying TPSA.

See Also

TPSAMaps Class


TPSAOrder Property

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..TPSAOrder Property
TPSAMaps Class See Also Send Feedback
Order of the underlying TPSA.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int TPSAOrder { get; }
Visual Basic
Public Shared ReadOnly Property TPSAOrder As Integer
    Get
Visual C++
public:
static property int TPSAOrder {
    int get ();
}

Remarks

Defined at the time Init is called.

See Also

TPSAMaps Class
TPSAMaps Members


TPSATerms Property

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..TPSATerms Property
TPSAMaps Class See Also Send Feedback
Number of terms of the underlying TPSA.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int TPSATerms { get; }
Visual Basic
Public Shared ReadOnly Property TPSATerms As Integer
    Get
Visual C++
public:
static property int TPSATerms {
    int get ();
}

Remarks

Defined at the time Init is called.

See Also

TPSAMaps Class
TPSAMaps Members


TPSAVariables Property

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..TPSAVariables Property
TPSAMaps Class See Also Send Feedback
Number of variables in the underlying TPSA.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int TPSAVariables { get; }
Visual Basic
Public Shared ReadOnly Property TPSAVariables As Integer
    Get
Visual C++
public:
static property int TPSAVariables {
    int get ();
}

Remarks

Defined at the time Init is called.

See Also

TPSAMaps Class
TPSAMaps Members


TPSAMaps.Create Enumeration

[image]

A Sandcastle Documented Class Library
TPSAMaps..::..Create Enumeration
TPSAMaps Class See Also Send Feedback
Enumeration used to tell the constructor whether to fully instantiate a new map, or else to define the pointers only deferring assignment.

Namespace: TPSA
Assembly: TPSA (in TPSA.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Create
Visual Basic
Public Enumeration Create
Visual C++
public enum class Create

Members

Member name | Value | Description
Instantiate | 0 |
PointersOnly | 1 |

See Also

TPSA Namespace